Issues resolved and all pages should be operational again.
Posted Aug 19, 2026 - 18:49 CEST
Update
Issues with the Content side of the Platform have been resolved. Coach issues remain and our team is working on restoring access.
Posted Aug 19, 2026 - 18:12 CEST
Monitoring
Issue has been identified, systems are recovering, and we are monitoring the recovery.
Posted Aug 19, 2026 - 17:42 CEST
Update
We are continuing to investigate this issue.
Posted Aug 19, 2026 - 17:41 CEST
Update
We are continuing to investigate this issue.
Posted Aug 19, 2026 - 17:23 CEST
Investigating
We are currently investigating an issue that is causing platform-wide slowness across all areas of the platform, and may in some cases result in errors. Our team is actively investigating the root cause of the issue.
Posted Aug 19, 2026 - 17:21 CEST
This incident affected: Showpad Coach, Showpad Content, and Showpad Platform.