Showpad is slow or failing to load

Incident Report for Showpad

Resolved

Our engineering team has fixed the issue. All systems have recovered and all services are stable again. Our sincere apologies for the inconvenience. We are investigating how this happened and how we can prevent it in the future.
Posted Mar 20, 2023 - 16:54 CET

Identified

Our engineering team is investigating an issue impacting the Showpad platform. Both users and administrators might experience slow loading times or certain areas of the platform being completely impossible to load.
Posted Mar 20, 2023 - 14:44 CET
This incident affected: Showpad Platform.