Experience builder - limited functionality

Incident Report for Showpad

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 11:32 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2026 - 10:12 CET

Identified

We have identified an issue that impacts adding assets to an experience and are working to resolve this.
Posted Mar 13, 2026 - 09:51 CET
This incident affected: Showpad Content.