The issue impacting Coach courses and paths, and some non-Coach functions, is now resolved. We apologize for the trouble and thank you for your patience.
Posted Apr 16, 2026 - 15:51 CEST
Update
This issue also impacts some non-Coach functions, such as Page editing. We are continuing to investigate.
Posted Apr 16, 2026 - 08:46 CEST
Update
We are continuing to investigate this issue internally and with our AWS partners
Posted Apr 16, 2026 - 08:26 CEST
Investigating
Users accessing My Assignments may encounter an error page. We are currently investigating this issue and will provide regular updates on our progress
Posted Apr 16, 2026 - 07:01 CEST
This incident affected: Showpad Coach, Showpad Content, Showpad Platform, and API & Integrations.