Our monitoring now shows load time performance has returned to normal.
Should you continue to experience slow loading times in your Showpad instance, or encounter a "service unavailable" message, please let our Support team know and they can work with you directly to further investigate and resolve the behavior.
Posted Jul 28, 2025 - 17:47 CEST
Monitoring
A fix has been implemented and we are seeing load times reduce. Once performance across the board is back to normal we'll send out a final update.
Posted Jul 28, 2025 - 17:27 CEST
Investigating
We have identified and are currently investigating an issue impacting the Showpad platform.
Both Users and Administrators might experience slow loading times or encounter a message stating “Service Unavailable”