Degraded performance

Incident Report for Showpad

Resolved

The issue has been resolved, and the platform has regained normal performance levels.
Posted Oct 06, 2025 - 15:05 CEST

Update

We are continuing to work on a fix for this issue.
Posted Oct 06, 2025 - 15:05 CEST

Identified

Our engineering team has identified the root cause of the issue, and are working to deploy a fix.
Posted Oct 06, 2025 - 14:52 CEST

Investigating

We are currently investigating an issue that is causing platform-wide slowness across all areas of the platform, and may in some cases result in errors. Our team is actively investigating the root cause of the issue.
Posted Oct 06, 2025 - 14:33 CEST
This incident affected: Showpad Platform.